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About This Guide  

This section describes the purpose, audience, organization, and conventions that are used in 
this iPECS Lync RCC Gateway User Guide.  

Purpose 
This guide introduces the iPECS Lync RCC Gateway and explains how to correctly install and 
activate services of the RCC Gateway. 

Audience 
This guide provides installation, configuration, and management information intended for 
installers and administrators of the iPECS Lync RCC Gateway. 

Document Organization 
This guide consists of this ‘About This Guide’ section, three chapters, and the Appendix listed 
below. 

 About This Guide 

 Chapter 1: Overview 

 Chapter 2: Installation and Set-up 

 Chapter 3: RCC Gateway Service 

 Appendix: A 

Document Conventions 
This section describes text formatting conventions and important notice formats used in this 
guide. 

Text formatting 
The narrative-text formatting conventions used in this guide are as follows: 

Convention Description 

Bold text Bold text indicates a button, menu item, or dialog box option you can 
click or select. 

Italic text A cross-reference or an important term. 

Code text A command prompt. 
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(P, S) Premium or Standard license to support function. 

(LIK, Unified, CM) Relevant system LIIK, iPECS Unified (UCP/eMG), CM to support 
function. 

Important notices 
The following icons and notices are used in this guide to convey important cautions and notes. 

CAUTION 

A caution statement alerts you to situations that may cause damage to hardware, software, or 
data.  

 

NOTE 

A note provides additional explanations, emphasis on important information, or a reference to 
related information. 
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Chapter 1.  
Overview 

This chapter is an overview of the iPECS RCC Gateway.  

1.1 Introduction of RCC Gateway 
The RCC Gateway is a Windows based application that is employed with the RCC Client for 
Lync providing call control for the user’s iPECS desk phone from the Lync screen. The Gateway 
acts as the communications link between the RCC Client and the iPECS host platform. The 
Gateway interprets client requests and delivers the request to the iPECS host. The iPECS host 
executes the request informing the Gateway of resulting actions, which the Gateway interprets 
and informs to the RCC Client. 

Additionally, the RCC Gateway monitors the status of other iPECS user devices informing the 
RCC Client, which, in turn, notifies the Lync Client to maintain appropriate telepresence. 

The RCC Gateway is compatible with all iPECS voice platforms including: 

 iPECS LIK 

 iPECS Unified (UCP and eMG) 

 iPECS CM 

1.2 Components of program 
The RCC Client employs CTI to communicate with the iPECS RCC Gateway, which connects to 
the iPECS platform. The RCC Gateway also monitors tele-presence from the iPECS, which is 
provided to Lync through the RCC Client.  
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Chapter 2.  
Installation and Set-up 

This chapter explains the RCC Gateway installation process and set-up including the 
requirements for the hardware and the operating system.  

2.1 System requirements 
The system requirements for installing and executing the RCC Gateway are as shown below. 
Note the processing power required increases with the number of users.  

The components of the screen or quality characteristics may vary according to the version and 
characteristics of operating system (OS) as well as the hardware.  

2.1.1 Under 1000 users 
 Processor: Quad Core 2.7G or higher 

 Main Memory: 4GB RAM minimum 

 OS: Windows 2008 R2 or later 

2.1.2 Over 1000 user 
 Processor: Quad Core 3.3G or higher 

 Main Memory: 4GB RAM minimum 

 OS: Windows 2008 R2 or later 

2.1.3 Additional requirements for specific functions 
 .NET Framework version 4.5.1 or a higher must be installed in the RCC Gateway server. 
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2.2 Installation RCC Gateway 
After preparing the installation environment (Section 2.1.1), the RCC Gateway wizard manages 
installation of the Gateway (Section 2.2.2). Once installed, the Manager is launched (Section 
2.3.2) and configured (Section 2.3.3) then the gateway Services are installed (Section 3.1) and 
started (Section 3.2).  

2.2.1 Pre-installation 
Prior to installation of the RCC Gateway, the following items should be completed. 

 Assure the iPECS platform is installed and operational. 

 Assure appropriate RCC Gateway and Client licenses are installed in the iPECS.  

 Assure the ELG-E TSP is installed and the iPECS is configured to support CTI with the 
Gateway server. 

 Assure .Net Framework 4.5.1 or higher is installed on the RCC Gateway server 

 Grant permission to all clients to establish a connection with the RCC Client. To grant 
permission the IP address and port must be reserved as below: 

1. Use the  command at the Windows command prompt to determine the IP 
address and port. 

2. Execute the following command using the IP address and port from step 1 above. 

”netsh http add urlacl url=http://xxx.xxx.xxx.xx:xxx/ user=Everyone” 

 

NOTE 

It is recommended you record the IP address and port as this data is required when installing 
the RCC Client. 
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2.2.2 Installation 
The RCC Gateway installation is managed by the Install Wizard, which is activated when the 
setup program in the RCC Gateway software package is opened. To begin the installation, 

１. Launch “/RCCGateway/Setup.exe” from the Gateway software package. This will open the 
Install Wizard. 

 

 
２. After the Install Wizard initializes, click the Next button to complete the installation settings. 
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３. When all settings are completed, click the Install button to begin installation. 

 

 
４. When the Wizard indicates the installation is completed, click the Finish button to finish the 

installation and close the Wizard. 
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2.2.3 Program re-installation 
The steps below explain what you need to do to re-installation or removal depending on the 
system you are using. If service is on running. 

In the UCP System 

１. Click the button of Tools > Stop service to terminate service. 

 

In the CM System 

１. Click the button of Register >Gateway Server, configuration window will be displayed. 

 

２. Click the button of Service Stop to close service. 

 

 

NOTE 

If service is on running, it should be closed prior to re-installation or removal. 
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2.3 Initial Set-up 
After completing the installation of the Gateway application, the Trunk access code, and the 
RCC gateway and iPECS PBX platform IP hosts must be configured. 

2.3.1 Trunk Access Code – (UCP) 
The Trunk Access Code is the digit(s) users must dial to access an outside line for placing a call 
to a destination external to the iPECS platform. The code is assigned under the ‘Dialing rules’ of 
the Windows OS Control Panel ‘Phone and Modem’ selection as shown below.  

You should also verify and, if needed, modify the Country/region, Area Code etc. 

 

 Typically the digit ‘9’ is employed as the code. 
 

NOTE 

The Phone & Modem settings, including the Trunk Access Code, for the RCC Gateway and 
RCC Client type must be the same. 

If any of the settings are changed, the RCC Gateway must be restarted. 
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2.3.2 Starting the Gateway Manager 
Start the RCC Gateway by launching the RCC Gateway Manager.exe file in the install directory 
used by the Install Wizard. This will open the Gateway Manager shown below. 

In the UCP System 

 

In the CM System 

 

NOTE 

Once the Gateway Service is started as described in Chapter 3, should the server experience a 
power restart, the Gateway Service will restart as well. However, the Gateway Manager is 
launched manually to manage the Service and view logs. 
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2.3.3 Set up the information of PBX 
After starting the Manager, the gateway server should be configured with the IP host information 
for the gateway and the iPECS Platform.  

In the UCP System 

１. Click Tools > Setting to enter the IP host information. 

２. Server Setting screen will be displayed. 

 

３. In the Server Setting screen enter the RCC Gateway and iPECS PBX IP host information, which 
allows the Gateway to communicate with the RCC Client and iPECS. 

 

RCC Gateway 

 IP Address—The IP address of the RCC Gateway for communication with the Client. 

 Port—The TCP port employed for gateway/client communications. 

 Monitoring Port—The TCP port employed for communications between the RCC Gateway 
Service and the Manager. 

PBX (iPECS Platform) 

 IP Address—The IP address of the iPECS platform for communication with the iPECS. 

 Port—The TCP port employed for iPECS/gateway communications. 
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Language 

 Language—The UI text language can be selected as English or Korean. 
４. After entering or modifying data, click OK. 

 

NOTE 

If any of the host data is altered, the RCC Gateway Manager and RCC Gateway Service must 
be restarted. 

 

In the CM System 

１. Click Register > CM Server to display the setting menu. 

 

２. On this menu, set all of information of RCC Gateway Servers to connect CM Server. 

 

 Related information is as below 
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Setting information 

CM REG 

CM IP / Port • Put in IP and port of CM Server. 
• Basic port of CM is 13222.  

CM Name • Put in the name of CM Server. 
• It is not mandatory. 

Memo • If there is specific things related to CM, put in. 
 

３. If all articles done and click the button of save, these will be displayed or updated at the bottom 
of screen. 

 

 If click the contents of bottom side, these will be displayed at upper side. 
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４. Select the CM Server you want to delete from the bottom of the screen and click the Delete 
button. Selected CM Server will be removed. 

 

５. If removed normally, it will be disappeared at upper and bottom side. If all of configuration done, 
click the button of Exit to close Registration of CM Server. 
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2.3.4 Set up TenantPrefix – (CM) 
 

１. Click Register >TenantPrefix to display the setting menu. 

 

２. This menu is to set up the information of tenant prefix for Client routing to proper  

 

 Related information is as below. 

Setting information 

TenantPrefixForm 

CM IP / Name 
• Selection with click the button of  in CM 

Server list which set up at CM REG. 
• Name copied automatically from that of CM 

REG. 

Index • Each CM Server has totally 254 number 
assigned and index is one of them. 

TenantPrefix • 6 digit provided per one index 

CompanyName • Company name of tenant. 

Memo • Specific things 
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NOTE 
In running status, if TenantPrefix updated, it takes around 5 minutes to apply at client. 

 
３. If click the button of Save, it will be displayed at the bottom of screen. 

 

 All of items which have already TenantPrefix will be updated. 
４. For elimination, TenantPrefix selected and then click the button of Delete. 
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５. If deleted normally, selected TenantPrefix will be disappeared at upper and bottom sides. 

 

NOTE 

All of contents in bottom of screen show that of CM server IP which selected in CM IP/Name. 

 
６. For auto-generation of TenantPrefix, first put in index, the first and second items of TenantPrefix 

and then click the button of TenantPrefix Auto Create. TenantPrefix will be generated with 
repeating the first and second items. 

 



 

 
18 iPECS Lync RCC Gateway User Guide - Issue 1.1 

７. If not used TenantPrefix, put in “000000” in the field of TenantPrefix or check “Not use 
TenantPrefix” (In case of single iPECS CM System.) 

 

８. In case of saving as Text File about all configured data, click the button of Out Text File and 
select Out File path. 

 

► Click the  button to select the Out File Path item and click the OK button. 
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► Put in File Name and click the button of Run. 

 

► File export is complete, click the OK button. 

 

９. For saving text file, click to the button of In Text file and go process as below. 
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► Click the In File Name  button to select the file to read. 

 

► Click the Run button. 

 

► Click the OK button. 
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► Click the Exit button. 

 

► To confirm contents, select the item of CM IP/Name. 
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１０. If all configuration done, click the button of Exit for termination of TenantPrefix setting. 
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2.3.5 Set up RCC Gateway server 
In the UCP System 

１. Click the Tools > Setting to open the Server Setting window. 

 

２. As below, the window of server setting will be displayed. 

 

３. In this window, set up the information for RCC Gateway connection to PBX(UCP), Client 
connection to RCC Gateway and language information. 

Setting Information 

RCC Gateway 

IP 
address 

• Put in the IP address of PC installed with RCC Gateway. 
Using this, client can connect RCC Gateway. 

Port • For connection of client and RCC Gateway.. 

Monitoring 
port 

• For exchange of monitoring information between RCC 
Gateway service and administrator. 

 

４. After done, restart as below. 
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In the CM System 

１. Click the Register >Gateway Server, window of set-up displayed 

 

２. This is for putting in critical items of RCC Gateway Server management and service control 
( Install/Uninstall/start/stop of service and Install/Uninstall of SNMP ) 

 

 This is for putting in critical items of RCC Gateway Server management and service control 
( Install/Uninstall/start/stop of service and Install/Uninstall of SNMP ) 

 Configuration information is as below. 

Setting Inforamtion 

GatewayRegForm 

GateWay 
IP/Port 

• Put in the IP and port of RCC Gateway Server for 
operation.  

• Port is basically 808. 

GateWay 
Name • Enter a name in RCC Gateway Server. 

LOG File 
name • Enter a log file name that occurs during operation. 

LOG Path • Click the button of  and select Log path. 

LOG Size • Unit is Megabyte.  

LOG • If log file is over assigned date, it will be erased. If 7 days 
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Policy Day assigned as LOG Policy Day, It will be saved till 7 days 
further from now. 

Memo • Enter the peculiarity or note. 
 

NOTE 

If there is changed contents after running of RCC Gateway Server, It could be applied after 
rebooting of RCC Gateway Server. 

 
► If select one of CM IP and click the  button, it will move to CM List. 

 
 

► CM Server registered in CM List can interwork with RCC Gateway Server. 
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► For elimination, select one of CM List and click the  button. 

 

 
３. If all configuration done, Click the Save button. 

 

４. Click the Exit button for termination of GatewayRegForm setting. 
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2.3.6 Set up client policy – (CM) 
 

１. If click the button of Register->ClientPolicy, screen of set-up displayed. 

 

２. This ClientPolicyForm is for local or geographical redundancy of RCC Gateway Server.  

３. Client can send certain signal to RCC Gateway Server periodically and RCC Gateway Server 
deliver backup IP to client as below configuration. If incident situation happened, client can 
connect RCC Gateway server registered in backup IP and keep normal operation. 

 

 Configuration information is as below. 

Setting Information 

GatewayRegForm 

Local 
GateWay IP 

• RCC Gateway Server IP for Client connection.  
• Read only. 

GateWay 
Name 

• Name of RCC Gateway Server. 
• Read only. 

Backup IP 
/Port 

• Put in IP and Port of RCC Gateway Server for incident 
situation.. 

Geo 
Redundancy 

• Enter multiple values separated by local and 
geographical redundancy. 

• Checked Backup IP in here will be set as lower priority. 

Backup IP 
List • All inputted item list by clicking  button. 

TenantPrefix  
View 

• Output of TenantPrefix that registered in RCC Gateway 
Server for reference. 
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４. To add at list, put in or select IP and port of Backup and Geo. Redundancy and click the 
button. 

 

５. For elimination, select one of list and click the  button. 

 

６. If all configuration done, Click the Save button.  
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７. Click the Exit button for termination of ClientPolicyForm setting. 

 

NOTE 

If clientpolicy updated in normal operation, it takes around 5 minutes for implementation of client. 
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2.3.7 Set up password preventing dual registration – (CM) 
From the version R1.0.21 of client software, new feature of password management in Client 
software added. If password forgotten, it can be found out or updated in RCC Gateway Server 
and informed to user as below.  

１. Click the Register > Reset Auth Password, below menu will be displayed. 

 

２. All list will be displayed and for update, select one of users. 

 

３. If click the button of Reset (Delete Password), password of user will be blank. 

４. If click the button of Random Password, password of user will be set as 6 digit randomly. 

５. If click the button of User Define, User password can be set in Password article. 

６. If update done, click the Save button for termination. 

NOTE 

Sometimes below message will be displayed.“Data Save fail Retry !!!”. This case denote some 
error happened in database so need to retry till this message disappeared. 
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2.3.8 Redundancy of RCC Gateway– (CM) 
When certain client needs connection change from A to B Gateway server, proceed as followed.  

１. If click the button of State->RCC Gateway, below menu will be displayed. 

 

２. In Gateway List, first thing is Local RCC Gateway Server and others are reserved RCC Gateway 
Server. 

 

► If click the button of GatewayList State Refresh, keep the status of RCC Gateway Server 
current. 

 

３. Below example is for both clients relocation to Local RCC Gateway Server from other RCC 
Gateway Server.  
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４. Select one of clients and Target Gateway IP. If all of Client selected, click the button of All Select 
and for clear, click the button of All Non Select. 

 

５. Click the button of Selected Client Move and move Client 

 

► Decision of execution 

 

６. Execute Selected Client Move, then selected number and related information will be displayed at 
select count. 

 

► After waiting around ( Maximum ) 5 minutes, click the button of GatewayList State Refresh for 
confirmation.  
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NOTE 
If Time synchronization didn’t between RCC Gateway Servers, waiting time will be increased.  

 
► Look for Client. Sometimes, there is specific cases that have to search or move particular client. 

For this, if select CM IP or put in condition of Client ID, Client IP and then click the button of 
Condition Display, particular client will be moved. ( all conditions are “AND”) 

 

► Below is example that put in 238 in Client to search a few clients including 238. 
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Chapter 3.  
RCC Gateway Service 

This chapter explains how to install and manage the RCC Gateway Service. 

3.1 RCC Gateway Service Installation 
１. Install the RCC Gateway Service by clicking Tools > Install Service. 

 

２. To verify the RCC Gateway Service is installed, use the Windows Task Manager Services 
management tool as below. To access the tool, press CTRL+ALT+DEL then select Start Task 
Manager. In the Task Manager select the Services tab then highlight the RCC Service item and 
click the Services button at the bottom right of the Task Manager screen. 
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3.2 Managing the RCC Gateway Service 

3.2.1 Starting the Service 
１. Start the Gateway Service by clicking Tools > Start Service. Once started, the RCC Gateway 

will permit connections to RCC Client types and establish communication with the iPECS 
platform. 

 

２. You can use the Windows Task Manager Services management tool, see Section 3.1, to verify 
the RCC Gateway Service status, which should display as Starting or Running. 

 

3.2.2 Stopping the Service 
１. You can stop the service by clicking Tools >Stop Service. When stopped, all client connections 

are terminated and communications with the iPECS platform stops. 

 

3.2.3 Uninstalling the Service 
１. You can uninstall the service by first stopping the service as described in section 3.2.2 then 

clicking Tools > Uninstall Service.  
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3.3 Monitoring RCC Gateway Service 

3.3.1 Gateway Manager Screen 
When the Gateway Service starts, communication with the iPECS platform is initiated and RCC 
Client types can connect with the gateway. The Gateway Manager screen displays log entries 
as shown below. 

On the left side of the screen is a list of active log entries in brief. Each entry includes the date 
and time, the status or type of entry (Client request, Information, Response, Event or Fault), and 
an Action. On the right is detailed information on the log entry highlighted in the left screen. 

The number of connected clients and the Service status are displayed in the bottom left of the 
screen. 

 

NOTE 

The color of the log entries vary based on the status of the log. 

3.3.2 Auto Scroll 
Normally the Gateway Manager refreshes continuously scrolling new entries in at the bottom of 
the list. You may stop the scrolling to select a specific entry to view by clicking View > Auto 
Scroll. 

 



 

 
iPECS Lync RCC Gateway User Guide - Issue 1.1 37 

3.3.3 Reading Stored Log Files 
The RCC Gateway Manager stores a log file for each minute there is activity. The log files are 
saved in the c:\temp\rccgatewaylog directory.  

１. To view the logs, click File > Open Log File. 

 

２. The list of saved Log files displays. 

 

３. When you double click on a log file, the file opens the RCC Manager saved log screen as shown 
below. 
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3.4 SNMP of RCC Gateway – (CM) 

3.4.1 SNMP of RCC Gateway installation 
 

１. If click the button of Register->Gateway Server, below menu will be displayed. 

 

２. The purpose of SNMP installation is to provide the operation of RCC Gateway Server thru. 
SNMP Service. If click the button of SNMP Install, CMD window appeared and installation will 
start ( Max. around 5 min waiting )  

３. If not finished over 5 minutes, close CMD window then root cause will be displayed.  

 

４. If done, the result will be displayed. If certain problem happened, that means that administrator 
authority or executed again in execution status.  
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3.4.2 SNMP of RCC Gateway elimination 
 

１. If click the button of Register->Gateway Server, below menu will be displayed.  

 

２. The purpose of SNMP uninstallation is to stop SNMP Service. If click the button of SNMP 
Uninstall, CMD window appeared and Uninstallation will start ( Maximum around 5 min waiting ) 
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３. If done, the result will be displayed. If certain problem happened, that means that administrator 
authority or executed again in execution status. 
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3.5 RCC gateway monitoring 

3.5.1 Screen of RCC Gateway monitoring 
If service running, the connection of client will be allowed and displayed as below. 

In the UCP System 

１. If RCC gateway executed, log in main screen will be displayed.  

２. You can monitor from the log screen on the main screen. 

 

 The left side of above is the log of PBX(UCP) and the right side of above is detail message 
which selected.  

 Each log consist of date, status, operation and detail message and each status value consist 
of Request, Response, Event, Fault. According to status, the color of log will be different. 

 The message of the number of client and service operation will be displayed in bottom side. 
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In the CM System 

１. If click the button of LOG >LOG Search, Gateway Log View will be displayed. 

 

２. If check Real Time Log View, on-time monitoring will be available. 

 

 The left side of above is the log of PBX(UCP) and the right side of above is detail message 
which selected.  

 Each log consist of date, status, operation and detail message and each status value consist 
of Request, Response, Event, Fault. According to status, the color of log will be different. 

 The message of the number of client and service operation will be displayed in bottom side. 
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3.6 View a Log 
In the UCP System 

１. Click the File > Open Log File to read log available. Basically log file will be saved in 
c:\temp\rccgatewaylog. 

 

２. If inquired log file opened, recorded log in file will be displayed. 

 

３. Through View > Auto Scroll, it can be assigned whether added file displayed continuously or 
stop auto-scroll. 
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In the CM System 

１. If click the button of LOG >LOG Search, window will be displayed. 

 

 Multi windows can be displayed and comparison of logs available. 
２. Below window is for searching for on-time log of RCC Gateway Server. 

 

Search Item 

Gateway LOG 
View 

Select Date • Date range for search. 

Time 
HH/MM/SS 

• Determine the time (HH / MM / SS) you want to start 
and finish for search. 

State • Select of request, response, event and error. 

Name • Searched when a value is entered in the Name. 

Content • Searched when a value is entered in the Content. 
 

３. If put in condition in content article and click the button of LOG Search, applicable data will be 
displayed. If click the button of LOG Search, the check of Real Time LOG View will be 
terminated. 
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 Above is a searched example. 
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Appendix A  
Useful Information 

This chapter provides information on the use of open source software.  

A.1 Open Source Software Notice 
Open Source Software used in this product are listed as below. You can obtain a copy of the 
Open Source Software License from Ericsson-LG Enterprise Web site, http://www.ericssonlg-
enterprise.com. Ericsson-LG Enterprise reserves the right to make changes at any time without 
notice. 

Open Source License 

ATAPI 1.4.0 MIT License  

  

  

  

  
 

Ericsson-LG Enterprise offers to provide you with open source code on CD-ROM for a charge 
covering the cost of performing such distribution, such as the cost of media, shipping and 
handling upon e-mail request to Ericsson-LG Enterprise at opensource@ericssonlg.com 

This offer is valid for a period of three (3) years from the date of the distribution of this product 
by Ericsson-LG Enterprise.  

 
 



 

 

 
 

 

www.ericssonlg-enterprise.com 
© Ericsson-LG Enterprise Co., Ltd. 2015 

The contents of this document are subject to revision without 
notice due to continued progress in methodology, design and 
manufacturing. Ericsson-LG Enterprise shall have no liability 
for any error or damage of any kind resulting from the use of 
this document. 

Posted In Korea 
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